RF1100se transceiver wired to breadboard

This is the way it looks like after the RF1100se transceiver is wired to my breadboard. In the middle of the breadboard you can see the Adafruit Pi Cobbler which is used to connect the lines with the Raspberry Pi’s GPIO.  Strictly speaking, there actually is no need  to use the Pi Cobbler, you directly can connect the appropriate GPIO headers with the headers on the RF1100SE.

on_breadboard

The Pinout of the RF1100SE is as follows:

Pinout

The Pinout of the Raspberry Pi is as follows:

GPIOsConnections:

3V3 Power <—> VDD
Ground      <—> GND
MOSI         <—> SI
MISO         <—> SO
CE0           <—> CSn
SCLK        <—> SCK

If we only communicate using the SPI bus, there is no need to connect the GDO0 or GDO2 header.

Advertisements

25 thoughts on “RF1100se transceiver wired to breadboard

  1. Hi There,
    I ve bought this device also, from ebay, and I bought a 915mhz version.
    I m struggling a lot to get them able to support 868mhz…
    as an example, if I use 2 of them with arduino min, and then use the rfbee library, they just talk together no problem.
    if I use this library on a panstamp device which also contains CC1101 device, then they also talk together.
    but if I put 868 mhz settings, nothing works….
    please let us know what experience you get with this rf1100se 🙂
    thx

    • My experience is positive: I used the same register settings like for the RFBee. The SPI operations are simple (see spi_test.c) and I just needed to do minor rewrites of the arduino code. So, finally, at this state I can receive the same message in the 868 MHz band as I did with the RFBee.

    • After having a detail look on the messages I receive over the air, I noticed that I only receive message from _one_ of my six radiator controllers: From the one that is closest to the receiver! So I guess you are right, and the antenna is not appropriate for the 868 MHz band, but for the 433 MHz band. Too bad. Honestly, I don’t know how to go on now.

    • See my reply above: It seemed to work pretty well in the 868 MHz band, but later I noticed that I can only receive the messages from one of my six radiator controller: From that one closest to the receiver. I guess there definitely is an issue with the antenna.

  2. Hi Wolfgang,
    I am currently testing two CC1101 chips onto my arduino.
    I have no pb sending/receiving datas using GFSK modulation at 433mhz.
    However, this is ASK/OOK demodulation which I want to use to “talk” with domotic home devices.
    Would you mind sharing your registers for OOD demodulation?

    Thanks,
    Erwan

    • Sorry, I don’t quite understand what you want to do, and I don’t know how it could help you to give you CC1101 register settings that only work for my specific hardware. But here is my advice: Get yourself the (free) SmartRF studio software from TI. It lets you play around with various RF settings of the CC1101 and will give you the resulting register settings. You don’t neccessarily need a TI CC1101 evaluation board for this, you can also make the software run in “offline” mode. You can get the software here: http://www.ti.com/tool/smartrftm-studio

  3. Hi Wolfgang,
    Thanks for your answer.
    I am indeed using smartrf which is a great software and helped find different settings for different modulations and/or frequencies.
    Still : I cannot find the proper settings in smartrf for ASK/OOK modulation.
    By that I mean i cannot get my tow CC1101 chips to talk to each other (whereas i manage this with other modulations such as GFSK).

    In short, if you happen to have register settings that work for ASK/OOK, I would gladly look at them 🙂

    Regards,
    Erwan

  4. Hi Wolfgang (actually this is nice place i have nice memories from there)
    OK. so i am also have RPi and got myself wonderful Wireless RF Transceiver Module 433MHz CC1101 CC1100 Remote Control Arduino Robot from ebay
    here is the link http://www.ebay.com/itm/171016720537?ssPageName=STRK:MEWNX:IT&_trksid=p3984.m1497.l2649

    i want to get this Transceiver controlling home automation RF devices like power sockets and light switches.

    so my question is that: the guy that sells the home automation RF devices sells those product with “smart” remote controler which i will buy. i want to receive those rf signals from the remore control and “record” them to my RPi and use that in scriprt to control those home automation RF devices.
    is that possible did you try this kind of secinaros

    i can provide more information if needed

    please let me know what you think

    10X

    • Just some thoughts from my side:
      To “record” a RF signal (with reasonable effort) you have to know details like carrier frequency, modulation, bitrate and so on. Check the registers of the CC1101 to get a feeling of how many register settings need to have the right values. As long as you don’t know the exact transmission parameters of your “smart” remote controller, I think you should forget your plan. I think you don’t want to do spectrum analysis of the RF signal and do reverse engineering on that. Maybe you want to have a look at FS20, I think the RF protocol used there is well known in the home automation community.

  5. Dear all

    I controll my lamps via ELRO power plugs with a simple 433RF Transmitter with 3 pins.
    I connect these 3 pins to my Rasperry-Pi (GPIO17, 5V-Power and Ground)

    Send-Command (in items-File):
    Switch Light_livingRoom_lamp “Lamp” (GF_Living) {exec=”OFF:./rcswitch-pi/send 11111 3 0, ON:./rcswitch-pi/send 11111 3 1″}

    So far so good – everything works.

    Now I changed my RF-Transmitter with a RF110SE Transceiver.
    I connected the pins as you described:
    3V3 Power VDD
    Ground GND
    MOSI SI
    MISO SO
    CE0 CSn
    SCLK SCK

    To send I use as before the rcswitch-pi modul. In the send.cpp file is the pin defined static to 0 (GPIO17).
    Therefore I tried all combination to connect MOSI, MISO, CEO and SCLK with GPIO17.
    But non of the combinations worked.

    Do you got an idea, what the error could be, or give me a simple example how to use ELRO power plugs through a RF1100SE Transceiver?

    Thanks for your help!

    • Sorry but I don’t know your “simple 433RF Transmitter with 3 pins”. I wonder how one can send a serial bitstream to the Transmitter with just one pin (GPIO17) and without a clock pin. To be honest, im totally clueless how this could work.

      The CC1101 on the other side has a well defined SPI interface, ideally for cases where you need to send or receive structured frames of data.

      I don’t know – if your “old” solution already works – why you should use a complex transceiver like the CC1101 for this task.

  6. I have a RF1100se transciever and i want to connect it to my raspberry pi and use fhem to control some EQ-3 Max devices. do you know if this could be possible?

    • EQ3 is a proprietary protocol, so you won’t be able to talk to the devices, unless you reingeneer the protocol and deal with authenthication/encryption that may be in place.

      • it seems that FHEM uses the EQ3 protocol, meanwhile i found out i need also an arduino (preferably arduino nano) to connect to RF1100se to make a device called CUL (CC1101 – USB – Lite module) and compile and load on the arduino a firmware called culfw. And this CUL connected to the Raspberry PI via USB will work with FHEM and EQ3. I think it can be possible to emulate an arduino on the Raspberry PI but i don’t know how to do that.

  7. Hi Wolfgang

    I purchased an RF1101SE because I intend to “read” the signal from a remote control of my power generator (https://fccid.io/YA3V750), which transmit at exactly 433.68 MHZ (or so the documentation says).

    I am using an Arduino uno, I haven´t tried with a Raspberry Pi, though.

    My question is this: what do I need to do to “read” the signal (whatever the data is) and then retransmit it whenever I want?

    I just want to start and stop my power gen automatically: Already have the hardware to check if there is power, servos for moving main switches, relays for opening and closing circuits, etc…

    But I´ve been fighting with this for over 1 week, and the little thing just won´t work the way I need… 😦

    So far, I haven´t found any code sample to suit my needs. Already downloaded a lib for the RF1101SE — but still it would seem I cannot make it work.

    I already got also the Smart RF studio from TI in order to proper setup the registers… still no luck — I press the remote control button next to the antenna and no data comes to the screen.

    Can you give me a good advice or point me in the right direction to resolve my issue?

    Thanks a lot!!

    -Edgar

    • What you are trying to do is maybe harder as you think. You seem to have no clue about the parameters of RF transmission, and also to speak to this cc1101 using SPI is not that easy. IMO you have to try harder to reverse engineer the RF communication: Can you open the remote? Can you attach probes to pins of the communication chip? You would need a small Logic Analyzer. If you think that this is to difficult, you maybe should get some help.

      • Hello, Wolfgang:

        Thanks for your reply, I really appreciate your input.

        The params for the RFI transmission are provided by the Smart RF studio — true, I am not in any way an expert in RF, I am a simple farmer trying to make my operation more efficient.

        I´d like some clarification as to why you suggest me to open the remote or probe it? I dont want to know if the codes to turn on and off the generator, I want to clone the analog signal that comes out of the remote whenever you press the on or off buttons….

      • Clone the analog signal? Okay, it seems I misunderstood you. I know about intelligent remote control units for home entertainment that are able to “Record” and replay infrared signal sequences, but never heard about non-hacker equipment that can do this for RF signal sequences. Another approach would be to ask a experienced Person to use a RF spectrum analyzer to reverse engineer the signal sequence and RF Parameters.

  8. hi,i need a loot of help please,i cant conect this module TI-CC1101 To my arduino nano

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s